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Introduction 

 

Pool monitoring is emerging as an integral 

component in the management of aquatic 

facilities, such as hotels, resorts and recreational 

centres, where pools play a central role in the 

guest experience. This advanced technology 

provides a proactive platform for maintaining the 

safety, hygiene and optimal operation of these 

recreational and relaxation spaces. 

 

A key element of pool monitoring is 

water quality control. Specialised sensors assess 

parameters such as pH level, chlorine 

concentration and turbidity. This continuous data 

collection gives operators instant insight into 

water chemistry, enabling informed decisions to 

maintain a hygienic and comfortable balance. 

The real strength of pool monitoring lies in its 

ability to provide a proactive approach to pool 

management. Through constant data collection 

and early detection of anomalies, managers can 

take preventative action before problems 

escalate. 

 

Theoretical framework 

 

It is essential to maintain the hygienic and 

sanitary quality of water in public and private 

swimming pools. A major challenge in these 

environments is gastrointestinal and skin 

diseases, among others, that arise due to the poor 

quality of the water used. It is therefore 

necessary to carry out supervision of the 

operations and maintenance of facilities for such 

aquatic activities. 

 

The variety of micro-organisms that can 

be transmitted to humans through the use of 

recreational waters such as Salmonella, Shigella, 

Klebsiella, Escherichia, Citrobacter, 

Pseudomonas, vibrio, Aeromonas, Enterovirus 

and protozoa, etc. 

 

Sensors and detection technologies 

 

A water quality sensor can be defined as a device 

that measures and monitors certain physical, 

chemical or biological parameters of water to 

assess its quality. Some of these include 

temperature, pH, turbidity, electrical 

conductivity, dissolved oxygen concentration 

and the presence of organic and inorganic 

pollutants. 

 

 

These systems provide real-time 

information and allow constant monitoring of 

water status, detection of anomalies, decision 

making and preventive or corrective action to 

avoid or reduce negative impacts on the 

environment and human health. 

 

IoT-based monitoring 

 

Several studies have explored the use of sensors 

for monitoring the waters of different aquifers 

such as rivers and lakes, using technologies 

based on the Internet of Things (IoT) and 

electronic prototyping platforms such as Arduino 

or computers based on boards such as Rasberry 

Pi. 

 

In the work carried out by , a review was 

made of the different IoT-based monitoring 

systems that have been developed to study 

different basins in different countries and 

regions, for the detection of pollutants, 

measurement of water quality and observation of 

aquifers in real time, demonstrating that this type 

of device can be vital for the efficient 

management of water resources. 

 

Data processing and algorithms 

 

Data processing is part of a broader subset 

known as 'information processing', which 

involves modifying (processing) information in 

any way that can be perceived by an observer. 

The process starts with data in its original state 

and transforms it into a more understandable 

format, such as graphics or documents. In this 

way, data is given the form and context 

necessary for computers to interpret it and for 

employees to use it throughout an organisation. 

 

Regulations and standards 

 

The regulations for swimming pools are given by 

the official Mexican standard nom-245-ssa1-

2010, sanitary requirements and water quality 

that swimming pools must meet. This standard 

establishes the sanitary specifications that 

swimming pools must meet in order to minimise 

or control health risks to users. 
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The sanitary control of water supplied for 

human use must be based on a risk assessment 

approach. This implies prioritising the 

characterisation and monitoring of control 

parameters, starting with the initial identification 

of the physico-chemical and bacteriological 

properties of the water. 

 

ESP32 microcontroller 

 

The ESP32 is selected for its Wifi and Bluetooth 

connectivity, low power consumption, broad 

compatibility, processing capabilities, 

programming flexibility, affordability and its 

efficient integration with the Internet of Things 

(IoT). 
 

 
 

Figure 1 

ESP32 module used in the project 

Source: naylamechatronics 

 

The ESP32 is a SoC (or combo chip, as 

referred to in the official documentation) that 

offers connectivity (Wifi and Bluetooth, with 2.4 

GHz frequency), computational power (CPU + 

memories), support for diverse communications 

operation, low-power operation support and 

dedicated security hardware blocks on a single 

chip. 

 

Arduino Nano 

 

The Arduino Nano is used as the main 

microcontroller in the project. It acts as the brain 

of the system, coordinating data acquisition from 

sensors, processing information and facilitating 

communication with other components. Its 

compact size and versatility make it ideal for 

integration into mechatronic solutions.  

 
 

Figure 2 

Arduino nano 

Source: Arduino Store 

 

20x4 I2C LCD Display 

 

The LCD Display 20×4 LCD2004 I2C which is 

an expander of digital inputs and outputs through 

serial communication. The LCD will be used to 

display relevant information such as sensor 

readings and alerts. 
 

 
 

Figure 3 

20x4 LCD screen 

Source: Units Electronics 

 

Sensors used 

 

PH Sensor Module 

 

The pH sensor is essential for measuring the 

acidity of water in swimming pools. Its 

incorporation allows for accurate monitoring and 

proactive decision making to maintain ideal 

levels, ensuring the safety and quality of the 

water. 

 

A pH sensor, also called a probe or 

electrode, is an important tool that allows the 

user to determine the alkalinity or acidity of a 

solution. The glass membrane at the tip is 

sensitive to H+ ions (Metler 
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Figure 4  

pH sensor module 

Source: Amazon 

 

Turbidity Sensor 

 

The turbidity sensor is used to assess water 

clarity in swimming pools. This measurement is 

crucial to ensure a safe and aesthetically pleasing 

environment. 

 

Turbidity is an optical characteristic that 

refers to the degree of clarity of a liquid. 

Turbidity levels can be measured with a turbidity 

meter. Turbidity in water is caused by individual 

suspended particles or colloidal matter scattering 

or obstructing the transmittance of light: the 

higher the concentration of suspended 

particles/colloidal matter, the higher the 

turbidity. Normally, these particles are too small 

to be detected by the human eye; therefore, 

turbidity measurement must be performed with a 

turbidity meter or turbidity analyser. (METLER 

TOLEDO, 2020) 

 
 

 
Figure 1 

Turbidity Sensor 

Source: Amazon 

 

DS18B20 Temperature Sensor 

 

The DS18B20 temperature sensor accurately 

detects water temperature in swimming pools, 

ensuring comfortable and safe conditions. Its 

integration allows for constant monitoring, 

facilitating the maintenance of ideal aquatic 

environments for users in hotel environments. 
 

 
 

Figure 6 

Temperature sensor 

Source: Units Electronics 

 

Analogue TDS sensor 

 

The TDS (Total Dissolved Solids) sensor 

measures the amount of dissolved particles in the 

water, providing an indication of its quality. In 

the project, it evaluates the concentration of 

dissolved solids. 

 

The TDS sensor measures the 

concentration of dissolved particles in the water, 

such as salts and minerals. The turbidity sensor, 

on the other hand, assesses water clarity by 

measuring the dispersion of suspended particles. 

Both sensors provide valuable information for 

water quality, but focus on different aspects: 

composition in the case of TDS and clarity in the 

case of turbidity. 
 

 
 

Figure 7 

TDS sensor 

Source: Didacticas electronics 

 

Logic Level Converter 

 

The 4-Channel Bidirectional 5V to 3.3V Logic 

Level Converter is essential to ensure 

compatibility between devices with different 

voltage levels. In the project, it facilitates 

communication between the Arduino Nano (5V) 

and the ESP32 (3.3V), ensuring reliable and safe 

operation. 
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Figure 8 

Logic level converter 

Source: Amazon 

 

Methodology 

 

Research Design 

 

The project uses a system development design 

that combines elements of software engineering, 

hardware and Internet of Things (IoT) 

technologies. By collecting data on the sensors 

processed on the Arduino, packaging data to 

display it on the LCD screen locally and sending 

the data to the ESP32 to enable a connection to 

the cloud, this other unpacks the data and enables 

remote viewing via the web page created in 

Vercel and hosted on Firebase. 

 

Prototype construction 

 

Design of the website: 

 

Vercel is a web hosting service that makes the 

process of implementing a web application really 

simple and fast. It allows our code to be 

deployed automatically every time we make 

changes to our code repository, which saves time 

and avoids complications. 

 

In addition, we are developing a web 

application using React and Next.js, and Vercel 

is optimised for these technologies. This means 

that it provides an ideal environment for 

developing and hosting web applications of this 

type, allowing us to focus on building the 

application rather than worrying about 

infrastructure and servers. 

 

In terms of programming language, we 

are using JavaScript, which is the primary 

language for web development in the browser. 

For modern web applications, JavaScript is 

combined with libraries and frameworks such as 

React to create dynamic and engaging user 

interfaces. This choice is natural since JavaScript 

is the language that runs directly in the user's 

browser and is widely supported. 

 

 
 

Figure 9 

Website design 

Source: own elaboration. 

 

Configuration and programming 

 

Programming on the Arduino Nano 

 

The programming of the Arduino Nano consists 

of reading various sensors (TDS, temperature, 

turbidity and pH) and transmitting this data to 

the ESP32 module for subsequent sending to a 

Firebase platform. 

 

Main loop: 

 

- A data request is made at regular intervals. 

 

- Temperature, pH, turbidity and TDS data 

are calculated and collected. 

 

- The LCD display is updated with the 

measured values. 

 

- The data is formatted and sent to the 

ESP32 via serial communication. 

 

Sensor Readout: 

 

An analogue reading is taken from the 

TDS sensor, using a median filter for more stable 

readings. 

 

The temperature is read by the DS18B20 

sensor and compensated with a compensation 

formula. 

 

A series of readings are taken to calculate 

turbidity and pH, averaging the values and 

applying specific formulas. 

 

Sending data to the ESP32: 

 

The collected data is formatted as strings 

and sent to the ESP32 via serial communication. 

The data includes information on temperature, 

TDS, turbidity and pH. 
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ESP 32 Programming 

 

Programming the ESP32 focuses on establishing 

and maintaining the WiFi connection, receiving 

data from the Arduino Nano via the serial port, 

and continuously updating the Firebase database 

with the collected information. The code is 

designed to ensure stable communication with 

Firebase and efficient management of data sent 

by the Arduino Nano. 

 

Initialization: 

 

- The WiFi connection is initiated and waits 

until the connection is established. 

 

- The necessary parameters such as API key 

and database URL are configured in 

Firebase. 

 

- Communication with Firebase is initiated 

and a callback function is assigned to 

handle the status of the token. 

 

Main loop: 

 

Waiting for the availability of the 

connection to Firebase. 

 

Data is sent to Firebase at a specific time 

interval, formatting the information and using the 

Firebase library to update the database in real 

time. 

 

Receiving Data from the Arduino Nano: 

 

Data is expected to be available on the 

serial port from the Arduino Nano. 

 

Data is received and stored in variables 

corresponding to temperature, TDS, turbidity and 

pH. 

 

Connection diagram 

 

The ESP32, the Arduino Nano and the website 

interact with each other to create a complete 

system. The system is designed to measure and 

send sensor data (such as pH, TDS, temperature 

and turbidity) to a real-time Firebase database, 

and then display this data on a web page. 

 
 

Figure 10 

Connection diagram 

Source: own elaboration. 
 

Interaction between components: 

 

- The ESP32 collects data from the sensors 

and sends it to Firebase. 

 

- The Arduino Nano takes care of reading 

and calibrating the various sensors, sending 

the data to the ESP32. 

 

- The web page queries Firebase to display 

the data to users. 

 

- The web page can be automatically 

updated to display real-time data. 

 

The complete system allows real-time 

monitoring and display of sensor data on a web 

page via a real-time Firebase database. The 

sensors provide measurements, the ESP32 acts as 

a data concentrator, the Arduino Nano takes care 

of the sensor readout and the website provides a 

user-friendly interface to access the data online. 

 

To access detailed technical information 

about the project, including collected data, 

source codes for the website, the Arduino Nano 

and the ESP32, as well as technical diagrams, a 

link to the platform is provided at the following 

link: [Link]. This resource centralises all 

technical aspects for a comprehensive review of 

the development and implementation of the 

Integrated Monitoring System. 

 

Installing ESP32 Support in the Arduino IDE. 

 

- Open the Arduino IDE. 

- Go to "File" -> "Preferences". 

- Under "Additional Board 

Configuration", add the ESP32 board 

manager URL: 

https://dl.espressif.com/dl/package_e

sp32_index.json. 
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- Go to "Tools" -> "Board" -> "Board 

Manager". 

- Search for "esp32" and install the 

support. 

 

- Select the ESP32 Card: 

 

- After installation, select the ESP32 

card in "Tools" -> "Board". 

 

- Port Configuration: 

 

- Connect the ESP32 to the computer. 

- Select the port to which it is 

connected in "Tools" -> "Port". 

 

- Open or copy the code: 

 

- Write the code in the Arduino IDE. 

- Ensure proper ESP32 library 

inclusion and essential functions. 

 

- Compile and Load: 

 

- Verify the code and upload the 

program to the ESP32 by selecting 

"Upload" in the IDE. 

 

- Serial Monitoring: 

 

- Open the "Serial Monitor" window to 

view the program output. 

- Set the baud rate according to the 

configuration. 

 

Results 

 

Extensive measurements were carried out using 

specialised sensors to assess the water quality in 

the pools of the hotel environment. The results 

obtained provide detailed insight into a number 

of key parameters. 

 

a) pH 

 

- Average value of the prototype: 7.2 

- Comparison with hotel equipment: 7.1 

 

b) Temperature: 

 

- Average value of the prototype: 28.5°C. 

- Comparison with the hotel equipment: 

28.4 

 

 

 

c) TDS (Total Dissolved Solids): 

 

- Prototype average value: 415 ppm. 

 

d) Turbidity: 

 

- Prototype average value: 4.5 UTN 

- Comparison with hotel equipment: No 

measurement was performed. 

 

System Performance: 

 

The prototype demonstrated reliable and 

stable performance during the testing phase. 

 

1. Wireless Communication: 

 

The ESP32 and the Arduino Nano 

maintained a stable connection, facilitating data 

transmission. 

 

2. Response Time: 

 

Real-time responses on the monitoring 

website. 

 

Successful Operation: 

 

The equipment operated successfully 

during all tests, meeting the required quality and 

safety standards. 

 

Web Server Connection: 

 

Effective integration with the web server 

enabled real-time visualisation of the collected 

data. 

 

Integration with Industry 4.0: 

 

The project demonstrated a solid 

integration with Industry 4.0 principles, enabling 

automation and data-driven decision making. 
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Figure 11 

Prototype data 

Source: own elaboration 

 

 
 

Figure 12 

Updating the website 

Source: own elaboration 

 

 
 

Figure 13 Online server 

Source: console.firebase.google.com 

 

Conclusions 

 

The success in the development of the prototype 

was evidenced by accurately establishing the 

communication between the ESP32 module and 

the real-time monitoring platform in Vercel. The 

implementation of a client with MQTT protocol 

allowed the creation of a graphical interface, 

enabling the instantaneous visualisation of 

readings from various sensors in the monitoring 

system. The relevance of the system was 

highlighted by achieving remote monitoring 

from any location with internet access, thus 

consolidating the effective integration of IoT 

technology in water quality management. 

 

 

 

 

This transition to Internet 4.0, especially 

in the field of the Internet of Things (IoT), is 

positioned as a fundamental tool in diverse fields 

such as mechatronics, hotel management and 

environmental sustainability. The project 

responds to the growing interest and need to 

understand how technological advances can 

positively impact the efficiency of monitoring 

and control of aquatic facilities. The 

implementation of visual interfaces and effective 

communication with Internet-connected devices 

reflect the commitment to technological 

innovation and continuous improvement in the 

field of engineering applied in this case to hotel 

environments. 

 

The versatility of the prototype allows its 

application in diverse areas, from recreational 

and residential facilities to industrial 

environments. Its ability to monitor and control 

water quality makes it an adaptable solution for 

swimming pools, water parks, wellness centres, 

industrial facilities and more, offering effective 

benefits in different contexts. 

 

Each of these contexts may require 

specific adjustments in design and 

implementation, but the basis of the monitoring 

and control system can be a versatile platform to 

address diverse needs in different sectors. 
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